Author Topic: Can't open @AllSamples.lsp  (Read 450 times)

zz

  • Member
  • *
  • Posts: 3
Can't open @AllSamples.lsp
« on: September 06, 2018, 01:25:04 AM »
When I run @AllSamples.lsp, it just returns a nil, showing no forms.

owenwengerd

  • Administrator
  • Hero Member
  • *****
  • Posts: 2980
    • Outside The Box
Re: Can't open @AllSamples.lsp
« Reply #1 on: September 06, 2018, 08:32:53 AM »
Have you installed OpenDCL? What happens if you enter OPENDCLDEMO at the command line?

khann

  • Full Member
  • ***
  • Posts: 153
Re: Can't open @AllSamples.lsp
« Reply #2 on: September 06, 2018, 08:37:23 PM »
Hi.
Owen, I had asked you this a long time ago.
at that time I could not find out the cause.

But after many times testing load the @AllSample.lsp file
I found that there's something wrong in the local language system.

At the posted image, there is unreadable characters in the comment line.
This is just a comment line,
but it seems that the local language (non english) Acad system cannot interpret the comment line.

Only after deleting all the collapsed character's comments
I could load the @Allsample.lsp file.

May this be helpful.  8)

« Last Edit: September 06, 2018, 08:46:45 PM by khann »

zz

  • Member
  • *
  • Posts: 3
Re: Can't open @AllSamples.lsp
« Reply #3 on: September 06, 2018, 08:40:23 PM »
I have installed opendcl 9.0.1.5 and loaded opendcl runtime. It won't return any information when I type "opendcldemo" in the command line.

Command: (LOAD "D:/Program Files (x86)/OpenDCL Studio/ENU/Samples/@AllSamples.lsp") nil
Command: OPENDCLDEMO
Command:
 

zz

  • Member
  • *
  • Posts: 3
Re: Can't open @AllSamples.lsp
« Reply #4 on: September 06, 2018, 08:51:47 PM »
It works when I delete all the unreadable characters in the comment line, thank you 8)

khann

  • Full Member
  • ***
  • Posts: 153
Re: Can't open @AllSamples.lsp
« Reply #5 on: September 06, 2018, 08:54:21 PM »
I found out this visual format option makes the collapsed comment line .


owenwengerd

  • Administrator
  • Hero Member
  • *****
  • Posts: 2980
    • Outside The Box
Re: Can't open @AllSamples.lsp
« Reply #6 on: September 07, 2018, 11:11:13 AM »
Interesting. Can you confirm that even the VLIDE-added formatting info comment causes a subsequent load failure? Or is it only the OpenDCL code comments that cause the load failure?

khann

  • Full Member
  • ***
  • Posts: 153
Re: Can't open @AllSamples.lsp
« Reply #7 on: September 08, 2018, 12:12:47 AM »
Hi, Owen.

mmm...
in my experience,

The VLIDE "Save format" option makes a special and automatic comments line
and if the user Acad system is non english based (just in my thought),
it makes something wrong characters.

In my Acad system, when saving .lsp file with this option,
it makes automatically something wrong charactors similar with the image but not the same.
After I found this, I never used the "Save format" option, maybe since 2005 ~~.

But I have not tested other languages Acad system.
That's all what I know till now.

Thanks.

owenwengerd

  • Administrator
  • Hero Member
  • *****
  • Posts: 2980
    • Outside The Box
Re: Can't open @AllSamples.lsp
« Reply #8 on: September 09, 2018, 02:48:54 PM »
Thanks for the feedback. For the next build of OpenDCL I have removed the problematic comments from the samples files.

khann

  • Full Member
  • ***
  • Posts: 153
Re: Can't open @AllSamples.lsp
« Reply #9 on: September 10, 2018, 04:15:57 AM »
What a kindness  :).
Thank you, Owen