Author Topic: New User Trying to Get the @AllSample to Work  (Read 100 times)

JustMarkInAz

  • Member
  • *
  • Posts: 2
New User Trying to Get the @AllSample to Work
« on: November 30, 2018, 09:23:53 AM »
Hello,
I've downloaded/installed OpenDCL Studio and I've downloaded the Tutorial for newbies.
In my "Support File Search Path", "Working Support File Search Path", and "Trusted Locations", I have included "C:\Program Files (x86)\OpenDCL Studio\ENU\Samples\".

I've followed the tutorial and I've dragged the @AllSamples.lsp" into my drawing.  I get the following:
 (LOAD "C:/Program Files (x86)/OpenDCL Studio/ENU/Samples/@AllSamples.lsp")
OPENDCLDEMO
Unknown command "OPENDCL".  Press F1 for help.
no function definition: DCL-FORM-ISACTIVE

So I went a little further and tried the "Hello World.lsp" program.  When I type in the command "Hello" it's recognized, but I still get:
HELLO
; error: no function definition: DCL_PROJECT_LOAD

I'm sure there is a step or something I didn't do.  I would really like to get started and learn all about this tool.  If someone could help me get out of the starting block, I'd really appreciate it.
I'm using AutoCAD 2015 SP2

Thanks,
Mark

roy_043

  • Sr. Member
  • ****
  • Posts: 349
Re: New User Trying to Get the @AllSample to Work
« Reply #1 on: December 01, 2018, 02:09:38 AM »
Have you perhaps installed ODCL while running AutoCAD?

owenwengerd

  • Administrator
  • Hero Member
  • *****
  • Posts: 2983
    • Outside The Box
Re: New User Trying to Get the @AllSample to Work
« Reply #2 on: December 02, 2018, 06:51:48 PM »
If the install was successful and you've restarted Acad afterward, the only other thing I can think of would be DEMANDLOAD turned off.

JustMarkInAz

  • Member
  • *
  • Posts: 2
Re: New User Trying to Get the @AllSample to Work
« Reply #3 on: December 05, 2018, 06:55:40 AM »
Hello, and thanks for your reply's.  I ended up resetting back to defaults and now when I drag the program into the drawing I get the sample dialog on the side.  Not sure why it didn't do it before, but I must have had something set it didn't like  :D

I'm looking forward to learning all about OpenDCL and hopefully some nice looking dialogs.

Best regards,
Mark