Author Topic: Foreign language support  (Read 8660 times)

LibertyOne

  • Member
  • *
  • Posts: 21
Foreign language support
« on: February 15, 2008, 03:21:28 AM »
In the German OpenDCL Localization Project I've noticed that sometimes the umlauts (you know, those foreign vowels with the dots, dashes and gizmos above them) aren't working. In my posts they somehow do, but in Fred's they don't. Does that have to do with a language setting?

For example: the word should be "darüber" and it shows as "darüber"

Fred Tomke

  • OpenDCL Technician
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2062
  • [ Mr. Bad Guy ]
    • Kommunale Entwicklungsplanung auf digitaler Basis - digital landscape and urban design
Re: Foreign language support
« Reply #1 on: February 15, 2008, 04:23:35 AM »
Hi LibertyOne,

Please have a look at your profile http://www.opendcl.com/forum/index.php?action=profile. Here you can select the language. You will see German twice. Try the last one and let's see if it helps.

Fred
Fred Tomke
Dipl.-Ing. (FH) Landespflege

[ landscaper - landscape developer - digital landscape and urban design]

LibertyOne

  • Member
  • *
  • Posts: 21
Re: Foreign language support
« Reply #2 on: February 16, 2008, 11:06:03 AM »
decisions, decisions, decisions...

ok, check this out -- I changed my language setting to "German" (the second one in the list) and I could then read all your umlauts, but mine were all replaced with a question mark. So I then tried the first "German" in the list. There were again all of your umlauts in hieroglyphics and mine were fine again. So I've opted to go back to English. But why is it so mixed up like that? I'm baffled. I can still read your messages in German but it's just annoying that the hieroglyphics are there.

One note that I should add though, is that I'm using an English keyboard and make my umlauts with ALT+####. (holding the alt key down while entering a 4 digit code) For example: for ue I type ALT+0252 which comes direct from the character map.

 

BazzaCAD

  • OpenDCL Webmaster
  • Administrator
  • Hero Member
  • *****
  • Posts: 853
  • Cylons will kill you
    • OpenDCL
Re: Foreign language support
« Reply #3 on: February 16, 2008, 11:22:06 AM »
The reason this is 2 versions is because one is "UTF-8" http://en.wikipedia.org/wiki/UTF-8 and the other isn't. But I'm not sure why it doesn't work for you and works for others. It sound more like the creation of them is the issue, but I don't have much experience in the area. Sorry
a.k.a.
Barry Ralphs
barryDOTralphsATgmailDOTcom

LibertyOne

  • Member
  • *
  • Posts: 21
Re: Foreign language support
« Reply #4 on: February 17, 2008, 03:55:37 PM »
testing 1...2...3...

ä ö ü ß Ä Ö Ü let's see if this is working...

Aleksandr Tkachenko

  • Member
  • *
  • Posts: 61
Re: Foreign language support
« Reply #5 on: February 19, 2008, 05:24:47 AM »
And Russian or a Ukranian language awakes?

LibertyOne

  • Member
  • *
  • Posts: 21
Re: Foreign language support
« Reply #6 on: February 20, 2008, 04:00:15 AM »
ä ö ü ß Ä Ö Ü

just another test - this time from a different computer and keyboard setting...  :)