Problems with OpenDCL Runtime Install

Started by mlmichel, February 16, 2024, 09:30:51 AM

Previous topic - Next topic



I will start at the beginning:

I was having the issue: _OPENDCL Unknown command "OPENDCL". So I read the forums and came to the conclusion I needed to install the OpenDCL Runtime because I did not see any .arx or .brx files in my OpenDCL Studio. directory

I installed OpenDCL Runtime and it still gives me: _OPENDCL Unknown command "OPENDCL".

I did some investigating into the OpenDCL Studio folder in my C: Directory and noticed that there aren't .arx files or .brx files. I have the original files from the OpenDCL installer.

Here is what I have tried:
1) add and remove programs > uninstall everything regarding OpenDCL > reinstall
2) restarting my computer after the uninstall > reinstall

Note: The OpenDCL Runtime installer seems to "crash" or not load fully when trying to install. It doesn't let me specify and install location. It doesn't bring up the window. I am suspecting that there are temporary files installed somewhere that can't be overwritten.

Also, the original folder specified for Open DCL in my C: drive cannot be written to, so I need to specify a different folder (desktop for example). Something to do with my IT department (one man show). Installing Runtime still does not seem to function correctly.

I am completely new to OpenDCL and lisp coding but am trying to harness the tools you have created to make my company more productive.


For reference, in my remove programs in windows settings, the size of the installation of OpenDCL Runtime is 144 KB. If that differs significantly from what files size you are viewing, let me know!


The runtime modules are installed in %ProgramFiles(x86)%\Common Files\OpenDCL, and the OPENDCL command is registered by the installer for demand loading in all supported CAD applications that are detected. You didn't mention which CAD application and version you're using, but it must enable demand loading (DEMANDLOAD=3).


Hello, thank you for your response. I just got around to tinkering with this.

I've done as you instructed, I see the files in my Common files directory. I have DEMANDLOAD set to 3.

1)I have my Support File Search Paths set to the both OpenDCL folders.

2)I am NOT seeing any OpenDCL files in my registry as mentioned in this forum:

  I can do a ctrl+f on the registry and search "opendcl" and it finds only one file:
     (default)     REG_SZ     OpenDCL.Project

I am using Civil 3D 2024 and by extension AutoCAD 2024.

I've read through a variety of forums and cannot fix this, it always seems that they solve the problem before my problem is solved.

Thank you for you help!

 - Maxwell


I have also tried dragging and dropping the .arx files into Civil 3D, it is displays:

Command: (ARXLOAD "C:/Program Files (x86)/Common Files/OpenDCL/OpenDCL.16.arx") ; error: ARXLOAD failed

Product Version: 13.6.1781.0 Civil 3D 2024.3 Update
Built on: U.152.0.0 AutoCAD 2024.1.2 Autodesk AutoCAD Map 3D 2024.0.1 AutoCAD Architecture 2024


Make sure you're installing OpenDCL (the current development version, not the stable version). That installer should create demand load registry keys as long as Acad 2024 is installed. You should not change any settings or search paths.



Thank you for your quick responses. I greatly appreciate them!

I am having new issues finally!

I am trying to load my OpenDCL file named "01_Dialog.odcl" with a modal dialog named "Description"

My lisp is saved in C:\Users\mmichel\Desktop\lisps that work\

My .odcl file is saved in C:\Users\mmichel\Desktop\lisps that work\

I have the current support file search paths set:
     C:\Users\mmichel\Desktop\Lisps that work\
     C:\Program Files (x86)\Common Files\OpenDCL
     C:\Program Files (x86)\OpenDCL Studio

I browsed through a couple forms and watched the "01_hello_world" videos and I have this problem:

autocad command:

Command: ; error: ADS request error

    AutoCAD Message

    Project failed to load!
    The file could not be found or an error occurred while reading the file.



    OpenDCL Runtime Error

    An OpenDCL function argument processing exception has occurred!

    Error: NIL value not allowed
    Function: dcl_Form_Show
    Argument: 0

Here is my lisp code:

(defun c:dia1 ()
  (load "C:\\Users\\mmichel\\Desktop\\lisps that work\\0.1.lsp")
(defun c:dia2 ()
  (command "_OPENDCL")
  (setq form (dcl-project-load "01_Dialog.odcl")) ; -> "Form1"
  (setq returnResult (odcl_form_IsActive Form1/Dialog_Option)) ; -> 1
(defun C:dia3()
  (EnsureProjectLoaded "01_Dialog.odcl") ;if this returns, all is well
  (if (not (opdcl_Form_IsActive Description))
    (odcl_Form_Show Description)
(defun c:dia4 ()
  (command "_OPENDCL")
  (dcl_project_load "01_Dialaog.odcl" T)
  (dcl_form_show 01_Dialog_Description)

If you don't mind, if you edit the code, can you paste the entire code? Otherwise my noobiness might be on full display.


dia2 and dia3 are what other forums recommended, these do not work either.

I am trying to be as descriptive as I can just in case others have similar issues in the future, but if you need any more information, let me know!