Author Topic: SlideView SetHighlight Problem  (Read 2968 times)

maweilian

  • Member
  • *
  • Posts: 5
SlideView SetHighlight Problem
« on: February 10, 2009, 09:26:11 AM »
To all:

I have a block library application I am working on where I need to select a block name in a listbox and have it highlight a slideview control.  Here is a screenshot of the dialog box.

The dialog has a series of 12 slides. Selecting a block name from the "block name" list box should highlight one of the 12 slides.  From my understanding of the OpenDCL Help file, this code:
(defun c:partlibmain_PartLibMain_ListBox1_OnSelChanged (ItemIndex Value /)
  (dcl_SlideView_SetHighlight partlibmain_PartLibMain_Slide2 1)
)

should result in the 2nd slide being highlighted in red.  But it is not working. What could I be doing incorrect?

I have attached the ODCL and LSP files for your review.

Thanks,
Will

owenwengerd

  • Administrator
  • Hero Member
  • *****
  • Posts: 3086
    • Outside The Box
Re: SlideView SetHighlight Problem
« Reply #1 on: February 10, 2009, 09:49:22 AM »
This is a bug, now fixed for Beta 7.

maweilian

  • Member
  • *
  • Posts: 5
Re: SlideView SetHighlight Problem
« Reply #2 on: February 10, 2009, 09:57:25 AM »
Great!  I will wait for Beta 7 then.  When will that be available for download?

Thanks,
Will

owenwengerd

  • Administrator
  • Hero Member
  • *****
  • Posts: 3086
    • Outside The Box
Re: SlideView SetHighlight Problem
« Reply #3 on: February 10, 2009, 06:42:29 PM »
I will probably upload Beta 7 sometime this weekend.